User avatar
User

Caius

Rank

New Republic Command

Posts

66

Joined

24 Jun 2014, 02:34

Game Exe Crash when Exiting Hyperspace

by Caius » 21 Jul 2016, 14:13

Getting a game exe crash on occasion when I perform a self-set jump from Dathomir (E6/F7) to Yavin (E7) with a loaded Gallofree transport.

More Details:
After pickung up some load at Last Nav Station, I moved the ship to sector E6/E7 in order to prepare for a jump into Yavin system. Set coordinates to E7 and entered hyperspace. FW exe crashed during the exit animation. I closed the "fwtow isn't working anymore" notification via tm and restarted the game. Then I respawned in Yavin, sector G7 (load is still there). The game didn't create a dump file. Time: today around 10:53 UTC

Additional Notes:

I've tried to reproduce it after it occured - at first with an e-wing char and then with the respawned gallofree by following the same steps I've mentioned above but this time it worked marvellously. On the other hand it happened quite a lot when I've tried the same route with a transport last sunday. Nvidia drivers are up to date. All launcher settings are either on max or turned on.
User avatar
User

FriendlyFire

Rank

Developer

Posts

1693

Joined

15 Feb 2010, 16:14

Re: Game Exe Crash when Exiting Hyperspace

by FriendlyFire » 21 Jul 2016, 14:57

Just to clarify: by exit animation, do you mean the transition from hyperspace to the destination system? If so, at which point during the animation did the crash happen: was the camera pulling out towards the back of the ship, static, or moving back to its regular position?

Also, did the crash make the game window vanish? Did it just turn black? Did you get a loading bar?
User avatar
User

Caius

Rank

New Republic Command

Posts

66

Joined

24 Jun 2014, 02:34

Re: Game Exe Crash when Exiting Hyperspace

by Caius » 21 Jul 2016, 15:14

Yep from hyperspace to destination. I didn't concentrate that much on the animation itself but if I remember correctly it's moving back to its regular position. Just happened again with a box freighter, same route. I'll have a closer look at the animation next time it occurs.

Game window just vanishes and the windows ftow error message appears. no loading bars. no black screen.

Edit
On second thought it crashes when the camera moves forward towards the transport before entering the destination system where the camera zooms back. Also I do get a black screen with the windows notification in the middle of the screen so the window does not really vanish. Only way to quit then is to use task manager. I've took a screen.
http://de.share-your-photo.com/img/d45d70a772.jpg.

Just got another crash with the box freighter in Kashyyyk (sector E5 > Cron Drift preset) but this time when entering hyperspace. Maybe I should try a reinstall.
Last edited by Caius on 21 Jul 2016, 16:28, edited 1 time in total.
User avatar
User

FriendlyFire

Rank

Developer

Posts

1693

Joined

15 Feb 2010, 16:14

Re: Game Exe Crash when Exiting Hyperspace

by FriendlyFire » 21 Jul 2016, 16:07

If you check the log files in My Games\Freeworlds, do you notice anything out of the ordinary at the end of the log file when a crash occurs?
User avatar
User

Caius

Rank

New Republic Command

Posts

66

Joined

24 Jun 2014, 02:34

Re: Game Exe Crash when Exiting Hyperspace

by Caius » 21 Jul 2016, 16:39

That's the last line of today's first and latest crash:

2016/07/21 12:50:44 1222107636 INFO [Deferred.cpp L: 755] "Generating cube map for system '..\TOW\universe\Systems\Yavin\Yavin.ini'."

2016/07/21 18:36:30 1800943133 INFO [Deferred.cpp L: 755] "Generating cube map for system '..\TOW\universe\Systems\Yavin\Yavin.ini'."

The logs usually end on that line when crashing into Yavin. The last crash happened when using the Kash/Yavin preset. I do see the destination system for a fraction of a second before crashing.

Who is online

Users browsing this forum: No registered users and 13 guests

Powered by phpBB ® | phpBB3 Style by KomiDesign
[ Time : 0.083s | 11 Queries | GZIP : Off ]
cron